Consultez gratuitement nos différents cours

  • Lignes de transmission (Télécommunications)

    Généralités   La propagation des ondes électromagnétiques dans le vide est en général différente de celle dans les lignes de transmissions d'une manière générale. On note que même s’il est difficile de déterminer le potentiel unique entre deux points sur une ligne dans le cas d'onde électromagnétique venant dans le temps, en mode TEM on peut le faire établir un effet dans les cas suivants: Le champ électrique est conservé sur toute ma surface plane transversale Le champ magnétique satisfait aux conditions...

    Lire la suite : Lignes de transmission

  • Réflexion de la lumière miroir plan (Science physique)

      Hypothèse de propagation de la lumière La lumière se propage en ligne droite Généralité La surface réfléchissante doit être plane pour éviter la diffusion de la lumière. Hypothèse de propagation Dans un milieu homogène transparent et isotrope la lumière se propage en ligne droite, exemple: dans l'air Généralité On appelle miroir plan en optique, toute surface plane et réfléchissante quelque soit sa nature, exemple: plaque métallique, plaque de verre, surface plane de l'eau. Loi de la réflexion ou loi...

    Lire la suite : Réflexion de la lumière miroir plan

  • Ligne de transmission sans pertes (Télécommunications)

    Généralités La propagation des ondes électromagnétiques dans le vide est généralement différente dans les lignes de transmission d'une manière générale. La structure du couple électromagnétique E,B varie avec la fréquence dans le cas où la longueur d'onde se rapproche de l'onde de grandeur du circuit de la ligne de transmission. Dans de telles conditions, les signaux sont fortement atténués sous les faibles distances. En dehors des guides d'onde, on peut utiliser au-delà de 100MHz à quelques GHz....

    Lire la suite : Ligne de transmission sans pertes

  • Les statistiques (Mathématique)

    La statistique est l'étude de caractères d'une population donnée. Ce caractère peut être qualitatif ou quantitatif. Exemple: Les élèves du lycée son nombreux et portent le bleu et le gris. Les statistiques portent essentiellement sur l'organisation des données qui comprennent: les modalités, les effectifs et fréquences. Exemple: Dans une classe de 3e, les notes attribuées aux élèves sont: 1; 10; 11; 0; 3; 2,5; 09; 13.   Gestion des données On entend par gestion des données toutes les parties du...

    Lire la suite : Les statistiques

Récursivité

La récursivité encore appelée récurrence en mathématique permet de réaliser des traitements répétitifs particulièrement complexes que les structures itératives classiques ne peuvent aborder facilement. Elle permet de simplifier la structure des programmes. On dit qu'il y'a récursivité lorsque la définition d'un objet fait apparaître l'objet lui-même.

 


Quelques exemples d'utilisation de la récursivité

Structure de données récursives

Exemple:

  • Les listes.
  • Les piles.
  • Les files.
  • Les arbres.

Le raisonnement récursif

Le raisonnement récursif comporte deux phases bien distinctes:

  • Une formulation simpliste ou triviale: qui permet d'arrêter les traitements récursif.
  • Une formulation récursive: qui permet de poursuivre le traitement, exemple: tant que la condition est vraie on exécute l'action.

 


Récursivité indirecte

Encore appelée récursivité cachée ou croisée, la récursivité indirecte a lieu lorsqu'une procédure appelle une seconde procédure qui à son tour appelle la première.
Exemples:
f(n) = g(n-1)
g(n) = f(n-1)

 


La récursivité directe

Ici la procédure s'appelle elle-même, la condition importante dans l'utilisation de la récursivité directe est que les objets engendrés par une définition récursive doivent être fini. Ainsi dans une procédure utilisant la récursivité directe on a deux notions:

  • La procédure s'appelle elle-même: on ne commence avec de nouvelle données.
  • Il y'a un texte de fin ou une condition d'arrêt: la procédure doit contenir une construction telle que dans certains cas l'évolution puisse se faire directement sans appel récursif. Pour cela il est souvent préférable d'indiquer le test de fin des appels récursifs en début de procédure. On a donc la formulation suivante:
    Premier cas:
    si condition_fin alors
    instruction
    sinon
    appel récursif
    fin si

    Deuxième cas:
    tant que non(condition_fin) faire
    appel récursif
    fin tant que
    instruction

 


Application

Fonction factorielle

La factorielle d'un nombre entier n est le produit des nombres entiers inférieurs ou égaux à ce nombre n. Cette définition peut se noter de plusieurs façons

  1. 0!=1
    1!=1
    2!=2
    3!=3x2x1
    N!=N(N-1)x...x2x1
  2. N!=1 si N=0
    N!=N(N-1)x...x2x1 si N>0
  3. N!=1 si N=0
    N!=N(N-1)! si N>0

fonction factorielle(N:entier):entier
var p, i: entier
début
si N=0 alors
factorielle ←1
sinon
p ← 1
pour i=1 à N faire
p ← i*P
fin pour
factorielle ← p
fin si
fin

Autre fonction

fonction factorielle(N: entier): entier
debut
si N=0 alors
factorielle ← 1
sinon
factorielle ← n*factorielle(n-1)
fin si
fin

Exécution

F0

F1

F2

F3

F4

N = 3
fact(3)

3*fact(2)
fact(2)

2*fact(1)
fact(1)

1*fact(0)
fact(0)

1

Fonction de Fibonacci

f0 ; f1=1
fn=fn-2+fn-1 si n>1
f(n)=n si n<=1
f(n)=f(n-2)+f(n-1) si n>1

Correction:

fonction fibonacci(n:entier):entier
début
si n<=1 alors
fibonacci ← n
sinon← fibonacci(n-1)+fibonacci(n-2)
fin si
fin